<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
<title>President Biden tapping into Strategic Petroleum Reserve to ease prices, raising ire of Republicans | Mississippi Politics and News - Y&#039;all Politics</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://yallpolitics.com/xmlrpc.php" />
<meta name='robots' content='max-image-preview:large' />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
var gtm4wp_datalayer_name = "dataLayer";
var dataLayer = dataLayer || [];
var gtm4wp_scrollerscript_debugmode         = false;
var gtm4wp_scrollerscript_callbacktime      = 100;
var gtm4wp_scrollerscript_readerlocation    = 150;
var gtm4wp_scrollerscript_contentelementid  = "content";
var gtm4wp_scrollerscript_scannertime       = 60;
//]]>
</script>
<link rel='dns-prefetch' href='//player.vimeo.com' />
<link rel='dns-prefetch' href='//w.soundcloud.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Mississippi Politics and News - Y&#039;all Politics &raquo; Feed" href="https://yallpolitics.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mississippi Politics and News - Y&#039;all Politics &raquo; Comments Feed" href="https://yallpolitics.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mississippi Politics and News - Y&#039;all Politics &raquo; President Biden tapping into Strategic Petroleum Reserve to ease prices, raising ire of Republicans Comments Feed" href="https://yallpolitics.com/2021/11/23/president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans/feed/" />
<link rel='stylesheet' id='wgs2-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/95y9vii3/284nt.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/1dzou22t/284nt.css' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-law-info-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/9mmcvnel/284nt.css' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-law-info-gdpr-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/7a9nfu6q/284nt.css' type='text/css' media='all' />
<link rel='stylesheet' id='email-subscribers-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/87u44jaf/284nt.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-wallop-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/78o9zc91/284nt.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-wallop-fade-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/6s38t1/284nt.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/lagzjw6o/284nt.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-image-widget-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/sfy8pti/284nt.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/folaemr1/284nt.css' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=10.3.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='cff-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/9htq24i9/86xlc.css' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/fpwa86gb/86xlc.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/l1dvi57d/284nt.css' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
@media (max-width: 767px) {
.td-header-desktop-wrap {
display: none;
}
}
@media (min-width: 767px) {
.td-header-mobile-wrap {
display: none;
}
}
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/qvjomoup/284nt.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/d5ifxdd3/284nt.css' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/1nzcc8ba/284nt.css' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css' href='//yallpolitics.com/wp-content/cache/wpfc-minified/dsbrbt67/284nt.css' type='text/css' media='all, print' />
<script type='text/javascript' src='https://yallpolitics.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='cookie-law-info-js-extra'>
/* <![CDATA[ */
var Cli_Data = {"nn_cookie_ids":[],"cookielist":[],"non_necessary_cookies":[],"ccpaEnabled":"","ccpaRegionBased":"","ccpaBarEnabled":"","strictlyEnabled":["necessary","obligatoire"],"ccpaType":"gdpr","js_blocking":"","custom_integration":"","triggerDomRefresh":"","secure_cookies":""};
var cli_cookiebar_settings = {"animate_speed_hide":"500","animate_speed_show":"500","background":"#FFF","border":"#b1a6a6c2","border_on":"","button_1_button_colour":"#000","button_1_button_hover":"#000000","button_1_link_colour":"#fff","button_1_as_button":"1","button_1_new_win":"","button_2_button_colour":"#333","button_2_button_hover":"#292929","button_2_link_colour":"#444","button_2_as_button":"","button_2_hidebar":"","button_3_button_colour":"#000","button_3_button_hover":"#000000","button_3_link_colour":"#fff","button_3_as_button":"1","button_3_new_win":"","button_4_button_colour":"#000","button_4_button_hover":"#000000","button_4_link_colour":"#62a329","button_4_as_button":"","button_7_button_colour":"#61a229","button_7_button_hover":"#4e8221","button_7_link_colour":"#fff","button_7_as_button":"1","button_7_new_win":"","font_family":"inherit","header_fix":"","notify_animate_hide":"","notify_animate_show":"","notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":"1","scroll_close_reload":"","accept_close_reload":"","reject_close_reload":"","showagain_tab":"","showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#000","show_once_yn":"1","show_once":"8000","logging_on":"","as_popup":"","popup_overlay":"1","bar_heading_text":"","cookie_bar_as":"banner","popup_showagain_position":"bottom-right","widget_position":"left"};
var log_object = {"ajax_url":"https:\/\/yallpolitics.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/cookie-law-info/public/js/cookie-law-info-public.js?ver=2.0.5' id='cookie-law-info-js'></script>
<script type='text/javascript' id='email-subscribers-js-extra'>
/* <![CDATA[ */
var es_data = {"messages":{"es_empty_email_notice":"Please enter email address","es_rate_limit_notice":"You need to wait for sometime before subscribing again","es_single_optin_success_message":"Successfully Subscribed.","es_email_exists_notice":"Email Address already exists!","es_unexpected_error_notice":"Oops.. Unexpected error occurred.","es_invalid_email_notice":"Invalid email address","es_try_later_notice":"Please try after some time"},"es_ajax_url":"https:\/\/yallpolitics.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/email-subscribers/lite/public/js/email-subscribers-public.js?ver=4.9.1' id='email-subscribers-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.13.1' id='gtm4wp-form-move-tracker-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-youtube.js?ver=1.13.1' id='gtm4wp-youtube-js'></script>
<script type='text/javascript' src='https://player.vimeo.com/api/player.js?ver=1.0' id='gtm4wp-vimeo-api-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-vimeo.js?ver=1.13.1' id='gtm4wp-vimeo-js'></script>
<script type='text/javascript' src='https://w.soundcloud.com/player/api.js?ver=1.0' id='gtm4wp-soundcloud-api-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-soundcloud.js?ver=1.13.1' id='gtm4wp-soundcloud-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/duracelltomi-google-tag-manager/js/analytics-talk-content-tracking.js?ver=1.13.1' id='gtm4wp-scroll-tracking-js'></script>
<link rel="https://api.w.org/" href="https://yallpolitics.com/wp-json/" /><link rel="alternate" type="application/json" href="https://yallpolitics.com/wp-json/wp/v2/posts/81812" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://yallpolitics.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://yallpolitics.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.8.2" />
<link rel="canonical" href="https://yallpolitics.com/2021/11/23/president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans/" />
<link rel='shortlink' href='https://yallpolitics.com/?p=81812' />
<link rel="alternate" type="application/json+oembed" href="https://yallpolitics.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fyallpolitics.com%2F2021%2F11%2F23%2Fpresident-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://yallpolitics.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fyallpolitics.com%2F2021%2F11%2F23%2Fpresident-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans%2F&#038;format=xml" />
<meta name="google-site-verification" content="o2OeOww-tg5do5ssm-e3upmTnYZEk0ClgFJUOJSZZHo" />
<script data-ad-client="ca-pub-8602591697930906" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script src="https://js.adsrvr.org/up_loader.1.1.0.js" type="text/javascript"></script>

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
var google_tag_params = {"pagePostType":"post","pagePostType2":"single-post","pageCategory":["2021","dc","elected-officials","electedofficials","headlines","lifestyle","local"],"pagePostAuthor":"Anne Summerhays","browserName":"Googlebot","browserVersion":"2.1","browserEngineName":"","browserEngineVersion":"","osName":"","osVersion":"","deviceType":"bot","deviceManufacturer":"","deviceModel":"","geoCountryCode":"(no geo data available)","geoCountryName":"(no geo data available)","geoRegionCode":"(no geo data available)","geoRegionName":"(no geo data available)","geoCity":"(no geo data available)","geoZipcode":"(no geo data available)","geoLatitude":"(no geo data available)","geoLongitude":"(no geo data available)","geoFullGeoData":{"success":false,"error":{"code":101,"type":"missing_access_key","info":"You have not supplied an API Access Key. [Required format: access_key=YOUR_ACCESS_KEY]"}}};
var dataLayer_content = {"visitorLoginState":"logged-out","pagePostType":"post","pagePostType2":"single-post","pageCategory":["2021","dc","elected-officials","electedofficials","headlines","lifestyle","local"],"pagePostAuthor":"Anne Summerhays","browserName":"Googlebot","browserVersion":"2.1","browserEngineName":"","browserEngineVersion":"","osName":"","osVersion":"","deviceType":"bot","deviceManufacturer":"","deviceModel":"","geoCountryCode":"(no geo data available)","geoCountryName":"(no geo data available)","geoRegionCode":"(no geo data available)","geoRegionName":"(no geo data available)","geoCity":"(no geo data available)","geoZipcode":"(no geo data available)","geoLatitude":"(no geo data available)","geoLongitude":"(no geo data available)","geoFullGeoData":{"success":false,"error":{"code":101,"type":"missing_access_key","info":"You have not supplied an API Access Key. [Required format: access_key=YOUR_ACCESS_KEY]"}},"google_tag_params":window.google_tag_params};
dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NBH2ZS3');//]]>
</script>

<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
window.tdb_globals = {"wpRestNonce":"ef605a9abe","wpRestUrl":"https:\/\/yallpolitics.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
</script>
<script>
window.tdwGlobal = {"adminUrl":"https:\/\/yallpolitics.com\/wp-admin\/","wpRestNonce":"ef605a9abe","wpRestUrl":"https:\/\/yallpolitics.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};
</script>
<script type="text/javascript">
var cli_flush_cache = true;
</script>

<script>
var tdBlocksArray = []; //here we store all the items for the current page
//td_block class - each ajax block uses a object of this class for requests
function tdBlock() {
this.id = '';
this.block_type = 1; //block type id (1-234 etc)
this.atts = '';
this.td_column_number = '';
this.td_current_page = 1; //
this.post_count = 0; //from wp
this.found_posts = 0; //from wp
this.max_num_pages = 0; //from wp
this.td_filter_value = ''; //current live filter value
this.is_ajax_running = false;
this.td_user_action = ''; // load more or infinite loader (used by the animation)
this.header_color = '';
this.ajax_pagination_infinite_stop = ''; //show load more at page x
}
// td_js_generator - mini detector
(function(){
var htmlTag = document.getElementsByTagName("html")[0];
if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
htmlTag.className += ' ie10';
}
if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
htmlTag.className += ' ie11';
}
if ( navigator.userAgent.indexOf("Edge") > -1 ) {
htmlTag.className += ' ieEdge';
}
if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
htmlTag.className += ' td-md-is-ios';
}
var user_agent = navigator.userAgent.toLowerCase();
if ( user_agent.indexOf("android") > -1 ) {
htmlTag.className += ' td-md-is-android';
}
if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
htmlTag.className += ' td-md-is-os-x';
}
if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
htmlTag.className += ' td-md-is-chrome';
}
if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
htmlTag.className += ' td-md-is-firefox';
}
if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
htmlTag.className += ' td-md-is-safari';
}
if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
htmlTag.className += ' td-md-is-iemobile';
}
})();
var tdLocalCache = {};
( function () {
"use strict";
tdLocalCache = {
data: {},
remove: function (resource_id) {
delete tdLocalCache.data[resource_id];
},
exist: function (resource_id) {
return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
},
get: function (resource_id) {
return tdLocalCache.data[resource_id];
},
set: function (resource_id, cachedData) {
tdLocalCache.remove(resource_id);
tdLocalCache.data[resource_id] = cachedData;
}
};
})();
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .td-animation-stack .entry-thumb, .post img";
var tdc_is_installed="yes";
var td_ajax_url="https:\/\/yallpolitics.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=10.3.9.1";
var td_get_template_directory_uri="https:\/\/yallpolitics.com\/wp-content\/plugins\/td-composer\/legacy\/common";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="show";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#ff7e00";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdBlockNonce="b3dafdd549";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-4828293-1"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-4828293-1');
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"item": {
"@type": "WebSite",
"@id": "https://yallpolitics.com/",
"name": "Home"
}
},
{
"@type": "ListItem",
"position": 2,
"item": {
"@type": "WebPage",
"@id": "https://yallpolitics.com/category/2021/",
"name": "2021"
}
}
,{
"@type": "ListItem",
"position": 3,
"item": {
"@type": "WebPage",
"@id": "https://yallpolitics.com/2021/11/23/president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans/",
"name": "President Biden tapping into Strategic Petroleum Reserve to ease prices, raising ire..."                                
}
}    
]
}
</script>
<link rel="icon" href="https://yallpolitics.com/wp-content/uploads/2019/10/Yall-Politics-Icon2.png" sizes="32x32" />
<link rel="icon" href="https://yallpolitics.com/wp-content/uploads/2019/10/Yall-Politics-Icon2.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://yallpolitics.com/wp-content/uploads/2019/10/Yall-Politics-Icon2.png" />
<meta name="msapplication-TileImage" content="https://yallpolitics.com/wp-content/uploads/2019/10/Yall-Politics-Icon2.png" />

<style>
.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
.tds-button2 .tdm-btn-text,
.tds-button2 i,
.tds-button5:hover .tdm-btn-text,
.tds-button5:hover i,
.tds-button6 .tdm-btn-text,
.tds-button6 i,
.tdm_block_list .tdm-list-item i,
.tdm_block_pricing .tdm-pricing-feature i,
.tdm-social-item i {
color: #ff7e00;
}
.tds-button1,
.tds-button6:after,
.tds-title2 .tdm-title-line:after,
.tds-title3 .tdm-title-line:after,
.tdm_block_pricing.tdm-pricing-featured:before,
.tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
.tds-progress-bar1 .tdm-progress-bar:after,
.tds-progress-bar2 .tdm-progress-bar:after,
.tds-social3 .tdm-social-item {
background-color: #ff7e00;
}
.tds-button2:before,
.tds-button6:before,
.tds-progress-bar3 .tdm-progress-bar:after {
border-color: #ff7e00;
}
.tdm-btn-style1 {
background-color: #ff7e00;
}
.tdm-btn-style2:before {
border-color: #ff7e00;
}
.tdm-btn-style2 {
color: #ff7e00;
}
.tdm-btn-style3 {
-webkit-box-shadow: 0 2px 16px #ff7e00;
-moz-box-shadow: 0 2px 16px #ff7e00;
box-shadow: 0 2px 16px #ff7e00;
}
.tdm-btn-style3:hover {
-webkit-box-shadow: 0 4px 26px #ff7e00;
-moz-box-shadow: 0 4px 26px #ff7e00;
box-shadow: 0 4px 26px #ff7e00;
}
</style>


<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="Mississippi Politics and News - Y&#039;all Politics" />
<meta property="og:title" content="President Biden tapping into Strategic Petroleum Reserve to ease prices, raising ire of Republicans" />
<meta property="og:url" content="https://yallpolitics.com/2021/11/23/president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans/" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Republicans point to Biden&#039;s war on American energy which makes nation less safe, more dependent.
Today, President Joe Biden announced his plan to have the Department of Energy release 50 million barrels of oil from the Strategic Petroleum Reserve (SPR) to lower gas and oil prices for Americans." />
<meta property="og:image" content="https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM.jpg" />
<meta property="og:image:url" content="https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM.jpg" />
<meta property="og:image:secure_url" content="https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM.jpg" />
<meta property="article:published_time" content="2021-11-23T10:25:13-06:00" />
<meta property="article:modified_time" content="2021-11-23T10:28:04-06:00" />
<meta property="og:updated_time" content="2021-11-23T10:28:04-06:00" />
<meta property="article:section" content="2021" />
<meta property="article:section" content="DC" />
<meta property="article:section" content="Elected Officials" />
<meta property="article:section" content="ElectedOfficials" />
<meta property="article:section" content="Headlines" />
<meta property="article:section" content="Lifestyle" />
<meta property="article:section" content="Local" />
<meta property="article:publisher" content="https://faceboook.com/yallpolitics" />


<meta name="twitter:title" content="President Biden tapping into Strategic Petroleum Reserve to ease prices, raising ire of Republicans" />
<meta name="twitter:url" content="https://yallpolitics.com/2021/11/23/president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans/" />
<meta name="twitter:description" content="Republicans point to Biden&#039;s war on American energy which makes nation less safe, more dependent.
Today, President Joe Biden announced his plan to have the Department of Energy release 50 million barrels of oil from the Strategic Petroleum Reserve (SPR) to lower gas and oil prices for Americans." />
<meta name="twitter:image" content="https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM.jpg" />
<meta name="twitter:card" content="summary_large_image" />




<style id="tdw-css-placeholder"></style></head>
<body data-rsssl=1 class="post-template-default single single-post postid-81812 single-format-standard td-standard-pack tribe-no-js president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans global-block-template-1 td-local-news single_template_2 white-menu td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/yallpolitics" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/MSYallPolitics" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/user/YallPolitics" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>

<div class="td-menu-login-section">
<div class="td-guest-wrap">
<div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
</div>
</div>

<div class="td-mobile-content">
<div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu" class="td-mobile-main-menu"><li id="menu-item-837" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-837"><a href="https://yallpolitics.com/category/daily-roundup/">Daily Roundup</a></li>
<li id="menu-item-299" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-299"><a href="https://yallpolitics.com/category/ms-legislature/">MS Legislature</a></li>
<li id="menu-item-295" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-295"><a href="https://yallpolitics.com/category/elected-officials/">Elected Officials</a></li>
<li id="menu-item-294" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-294"><a href="https://yallpolitics.com/category/dc/">DC</a></li>
<li id="menu-item-78263" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78263"><a href="https://yallpolitics.com/category/economicfreedom/">Economic Freedom</a></li>
<li id="menu-item-297" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-297"><a href="https://yallpolitics.com/category/features/">Features</a></li>
<li id="menu-item-293" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293"><a href="https://yallpolitics.com/about-us/">About Us</a></li>
</ul></div> </div>
</div>

<div id="login-form-mobile" class="td-register-section">
<div id="td-login-mob" class="td-login-animation td-login-hide-mob">

<div class="td-login-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Sign in</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
<div class="td-login-info-text">
<a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
</div>
<div class="td-login-register-link">
</div>
</div>
</div>
<div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">

<div class="td-forgot-pass-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Password recovery</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
</div>
</div>
</div>
</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://yallpolitics.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-1 ">
<div class="td-header-top-menu-full td-container-wrap td_stretch_container">
<div class="td-container td-header-row td-header-top-menu">

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<div class="td-login-wrap">
<a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap ">
<div class="td-container td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://yallpolitics.com/">
<img class="td-retina-data" data-retina="https://yallpolitics.com/wp-content/uploads/2017/11/yallpolitics-logo.png" src="https://yallpolitics.com/wp-content/uploads/2017/11/yallpolitics-logo.png" alt="" />
<span class="td-visual-hidden">Mississippi Politics and News &#8211; Y&#039;all Politics</span>
</a>
</div>
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">
<div class="td-a-rec td-a-rec-id-header  tdi_1_591 td_block_template_1">
<style>
/* custom css */
.tdi_1_591.td-a-rec{
text-align: center;
}.tdi_1_591 .td-element-style{
z-index: -1;
}.tdi_1_591.td-a-rec-img{
text-align: left;
}.tdi_1_591.td-a-rec-img img{
margin: 0 auto 0 0;
}@media (max-width: 767px) {
.tdi_1_591.td-a-rec-img {
text-align: center;
}
}
</style><div class="td-all-devices">
<div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>

<script type="text/javascript" src="https://g.adspeed.net/ad.php?do=js&zid=93254&oid=23225&wd=-1&ht=-1&target=_blank"></script>
</div>
</div></div>
</div> </div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap td_stretch_container">
<div class="td-header-menu-wrap td-header-gradient ">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-mobile" href="https://yallpolitics.com/">
<img class="td-retina-data" data-retina="https://yallpolitics.com/wp-content/uploads/2017/11/yallpolitics-logo.png" src="https://yallpolitics.com/wp-content/uploads/2017/11/yallpolitics-logo.png" alt="" />
</a>
<a class="td-header-logo td-sticky-mobile" href="https://yallpolitics.com/">
<img class="td-retina-data" data-retina="https://yallpolitics.com/wp-content/uploads/2017/11/yallpolitics-logo.png" src="https://yallpolitics.com/wp-content/uploads/2017/11/yallpolitics-logo.png" alt="" />
</a>
</div>
<div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-837"><a href="https://yallpolitics.com/category/daily-roundup/">Daily Roundup</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-299"><a href="https://yallpolitics.com/category/ms-legislature/">MS Legislature</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-295"><a href="https://yallpolitics.com/category/elected-officials/">Elected Officials</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-294"><a href="https://yallpolitics.com/category/dc/">DC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-78263"><a href="https://yallpolitics.com/category/economicfreedom/">Economic Freedom</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-297"><a href="https://yallpolitics.com/category/features/">Features</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-293"><a href="https://yallpolitics.com/about-us/">About Us</a></li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://yallpolitics.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-2">
<article id="post-81812" class="post-81812 post type-post status-publish format-standard has-post-thumbnail category-164 category-dc category-elected-officials category-electedofficials category-headlines category-lifestyle category-local" itemscope itemtype="https://schema.org/Article">
<div class="td-pb-row">
<div class="td-pb-span12">
<div class="td-post-header">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://yallpolitics.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in 2021" class="entry-crumb" href="https://yallpolitics.com/category/2021/">2021</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">President Biden tapping into Strategic Petroleum Reserve to ease prices, raising ire...</span></div></div>
<ul class="td-category"><li class="entry-category"><a href="https://yallpolitics.com/category/2021/">2021</a></li><li class="entry-category"><a href="https://yallpolitics.com/category/dc/">DC</a></li><li class="entry-category"><a href="https://yallpolitics.com/category/elected-officials/">Elected Officials</a></li><li class="entry-category"><a href="https://yallpolitics.com/category/electedofficials/">ElectedOfficials</a></li><li class="entry-category"><a href="https://yallpolitics.com/category/headlines/">Headlines</a></li><li class="entry-category"><a href="https://yallpolitics.com/category/lifestyle/">Lifestyle</a></li><li class="entry-category"><a href="https://yallpolitics.com/category/local/">Local</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">President Biden tapping into Strategic Petroleum Reserve to ease prices, raising ire of Republicans</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://yallpolitics.com/author/anne/">Anne Summerhays</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-11-23T10:25:13-06:00">November 23, 2021</time></span> </div>
</header>
</div>
</div>
</div> 
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-sharing-top"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://yallpolitics.com/2021/11/23/president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fyallpolitics.com%2F2021%2F11%2F23%2Fpresident-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=President+Biden+tapping+into+Strategic+Petroleum+Reserve+to+ease+prices%2C+raising+ire+of+Republicans&url=https%3A%2F%2Fyallpolitics.com%2F2021%2F11%2F23%2Fpresident-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans%2F&via=MSYallPolitics">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://yallpolitics.com/2021/11/23/president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans/&amp;media=https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM.jpg&description=President+Biden+tapping+into+Strategic+Petroleum+Reserve+to+ease+prices%2C+raising+ire+of+Republicans">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=President+Biden+tapping+into+Strategic+Petroleum+Reserve+to+ease+prices%2C+raising+ire+of+Republicans %0A%0A https://yallpolitics.com/2021/11/23/president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content tagdiv-type">
<div class="td-post-featured-image"><a href="https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM.jpg" data-caption=""><img width="696" height="553" class="entry-thumb td-modal-image" src="https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM-696x553.jpg" srcset="https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM-696x553.jpg 696w, https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM-300x238.jpg 300w, https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM-768x610.jpg 768w, https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM-529x420.jpg 529w, https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM.jpg 788w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="Biden" /></a></div>
<h3><span style="color: #ff9900;"><em>Republicans point to Biden&#8217;s war on American energy which makes nation less safe, more dependent.</em></span></h3>
<p>Today, President Joe Biden announced his plan to have the Department of Energy release 50 million barrels of oil from the Strategic Petroleum Reserve (SPR) to lower gas and oil prices for Americans.</p>
<p>The White House says the Biden Administration&#8217;s announcement to tap the strategic reserve is part of a global effort from energy-consuming nations to curb rising fuel prices. The U.S., India, China, Japan, Republic of Korea and the United Kingdom have coordinated concurrent releases.</p>
<p>The Strategic Petroleum Reserve is a complex of four locations that stockpile emergency oil in deep underground storage caverns created in salt domes along the Texas and Louisiana Gulf Coasts.</p>
<script type="text/javascript" src="https://g.adspeed.net/ad.php?do=js&zid=95923&oid=23225&wd=-1&ht=-1&target=_blank&noerror=1"></script>

<p>A total of <a href="https://www.cnbc.com/2021/11/23/biden-says-us-will-tap-strategic-petroleum-reserve-as-gas-prices-hover-around-7-hear-high.html">50 million barrels</a> will be released from the SPR by the U.S. Of the 50 million barrels, 32 million barrels will be an exchange over the next several months. The other 18 million of these barrels will be an acceleration of a previously authorized sale.</p>
<p>The <a href="https://www.gasbuddy.com/usa">average gas price</a> in Mississippi is over $3.00 per gallon, at $3.02 as of today. In California, it sits at $4.69. According to <a href="https://gasprices.aaa.com/state-gas-price-averages/#:~:text=State%20Gas%20Price%20Averages%20%20%20%20State,%20%20%243.522%20%2047%20more%20rows%20">AAA</a>, the nation&#8217;s average gas price per gallon has reached $3.40.</p>
<p>Mississippi U.S. Senator Roger Wicker says President Biden tapping the nation&#8217;s strategic reserve rather than ending  &#8220;his war on American energy&#8221; is putting a Band-Aid on a wound Biden created.</p>
<script type="text/javascript" src="https://g.adspeed.net/ad.php?do=js&zid=95120&oid=23225&wd=-1&ht=-1&target=_blank&noerror=1"></script>

<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">President Biden is tapping our Strategic Petroleum Reserve rather than ending his war on American energy.<br /> <br />He is putting a Band-Aid on a wound he created.<br /> <br />There is a solution to soaring gas prices, but this is not it.<br /> <a href="https://t.co/HlwusdeG1R">https://t.co/HlwusdeG1R</a></p>
<p>&mdash; Senator Roger Wicker (@SenatorWicker) <a href="https://twitter.com/SenatorWicker/status/1463174657771720717?ref_src=twsrc%5Etfw">November 23, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Fellow Magnolia State Senator Cindy Hyde-Smith tweeted her disdain for the Biden Administration&#8217;s move, calling it &#8220;short-sighted and inadequate.&#8221;</p>
<p>&#8220;To truly help our nation, the White House needs to reverse the policies that put our energy security at risk,&#8221; Hyde-Smith tweeted.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">.<a href="https://twitter.com/POTUS?ref_src=twsrc%5Etfw">@POTUS</a> tapping the Strategic Petroleum Reserve (which is meant for emergencies) is short-sighted &amp; inadequate action to address Biden-caused record spikes at gas pumps. To truly help our nation, the <a href="https://twitter.com/WhiteHouse?ref_src=twsrc%5Etfw">@WhiteHouse</a> needs to reverse the policies that put our energy security at risk.</p>
<p>&mdash; U.S. Senator Cindy Hyde-Smith (@SenHydeSmith) <a href="https://twitter.com/SenHydeSmith/status/1463179400682291213?ref_src=twsrc%5Etfw">November 23, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Last week, Congressman Michael Guest (MS-03) and other <a href="https://guest.house.gov/sites/guest.house.gov/files/Strategic%20Petroleum%20Reserve%20Letter_.pdf" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?q=https://guest.house.gov/sites/guest.house.gov/files/Strategic%2520Petroleum%2520Reserve%2520Letter_.pdf&amp;source=gmail&amp;ust=1637761589963000&amp;usg=AOvVaw1LPYt_Y9P2Jus1FLGMxnoX">Republicans sent a letter</a> to the Biden Administration opposing the White House&#8217;s move to use the SPR to curb rising gas prices. The Representatives proposed an alternative strategy to releasing the oil reserves: increasing domestic oil production.</p>
<div class="page" title="Page 1">
<div class="layoutArea">
<div class="column">
<p><img loading="lazy" class="wp-image-78434 alignright" src="https://yallpolitics.com/wp-content/uploads/2021/07/Impeachment-Speech-Guest.jpg" alt="" width="185" height="163" srcset="https://yallpolitics.com/wp-content/uploads/2021/07/Impeachment-Speech-Guest.jpg 474w, https://yallpolitics.com/wp-content/uploads/2021/07/Impeachment-Speech-Guest-300x265.jpg 300w" sizes="(max-width: 185px) 100vw, 185px" /></p>
<p>The Congressmen stated that it would be in the country&#8217;s best interest to reopen oil and gas production on federal lands, which would equate to a 20% increase in our domestic oil production. If reserves from the SPR were withdrawn that are currently priced at $29/per barrel and forced to replace them at a cost of over $80/per barrel (and growing), it would create an &#8220;economic nightmare&#8221; for taxpayers.</p>
</div>
</div>
</div>
<div class="page" title="Page 2">
<div class="section">
<div class="layoutArea">
<div class="column">
<p>&#8220;Resorting to withdrawals from the SPR only postpones reality and creates larger economic concerns for the future,&#8221; the House members wrote. &#8220;At a time when we will undoubtably have harsh winter storms and hurricanes, along with an uncertain global geopolitical environment, future withdrawals from the SPR may be urgently needed. We must ensure the SPR is fully stocked and able to protect Americans the way it was intended to.&#8221;</p>
<div class="page" title="Page 1">
<div class="layoutArea">
<div class="column">
<p>The Republicans state that the country must continue to reserve the world’s largest supply of emergency crude for national emergencies that cannot otherwise be prevented.</p>
<script type="text/javascript" src="https://g.adspeed.net/ad.php?do=js&zid=101565&oid=23225&wd=-1&ht=-1&target=_blank"></script>

</div>
</div>
</div>
</div>
</div>
</div>
</div>
<p>Read the full letter from the Congressmen to the Biden Administration below:</p>
<p style="margin: 12px auto 6px auto; font-family: Helvetica,Arial,Sans-serif; font-style: normal; font-variant: normal; font-weight: normal; font-size: 14px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; display: block;"><a style="text-decoration: underline;" title="View House Republican letter to White House regarding SPR on Scribd" href="https://www.scribd.com/document/541830664/House-Republican-letter-to-White-House-regarding-SPR#from_embed">House Republican letter to White House regarding SPR</a> by <a style="text-decoration: underline;" title="View yallpolitics's profile on Scribd" href="https://www.scribd.com/user/15351287/yallpolitics#from_embed">yallpolitics</a> on Scribd</p>
<p><iframe loading="lazy" id="doc_35049" class="scribd_iframe_embed" title="House Republican letter to White House regarding SPR " src="https://www.scribd.com/embeds/541830664/content?start_page=1&amp;view_mode=scroll&amp;access_key=key-fd03NDNOLrlkrNOxJ1Jb" width="100%" height="600" frameborder="0" scrolling="no" data-auto-height="false" data-aspect-ratio="0.7729220222793488"></iframe></p>

</div>
<footer>
<div class="td-post-source-tags">
</div>
<div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://yallpolitics.com/2021/11/23/president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fyallpolitics.com%2F2021%2F11%2F23%2Fpresident-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=President+Biden+tapping+into+Strategic+Petroleum+Reserve+to+ease+prices%2C+raising+ire+of+Republicans&url=https%3A%2F%2Fyallpolitics.com%2F2021%2F11%2F23%2Fpresident-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans%2F&via=MSYallPolitics">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://yallpolitics.com/2021/11/23/president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans/&amp;media=https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM.jpg&description=President+Biden+tapping+into+Strategic+Petroleum+Reserve+to+ease+prices%2C+raising+ire+of+Republicans">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=President+Biden+tapping+into+Strategic+Petroleum+Reserve+to+ease+prices%2C+raising+ire+of+Republicans %0A%0A https://yallpolitics.com/2021/11/23/president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://yallpolitics.com/2021/11/23/wicker-hyde-smith-announce-261-7-million-army-contract-to-louisville-company/">Wicker, Hyde-Smith announce $261.7 million army contract to Louisville company</a></div></div><div class="td-next-prev-separator"></div></div> <div class="author-box-wrap"><a href="https://yallpolitics.com/author/anne/"><img alt='' src='https://secure.gravatar.com/avatar/ce3a8844dfc7664cdbb4f47c3954b58b?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ce3a8844dfc7664cdbb4f47c3954b58b?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' loading='lazy' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://yallpolitics.com/author/anne/">Anne Summerhays</a></span></div><div class="td-author-url"><a href="https://www.yallpolitics.com">https://www.yallpolitics.com</a></div><div class="td-author-description">Anne Summerhays is a native of Louisiana who joined Y'all Politics in 2021. She covers stories involving the Mississippi Legislature, education and business. She is a recent graduate of Millsaps College where she earned a degree in Political Science and minors in American Studies and Sociology.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Anne Summerhays"></span><meta itemprop="datePublished" content="2021-11-23T10:25:13-06:00"><meta itemprop="dateModified" content="2021-11-23T10:28:04-06:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://yallpolitics.com/2021/11/23/president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://yallpolitics.com/wp-content/uploads/2017/11/yallpolitics-logo.png"></span><meta itemprop="name" content="Mississippi Politics and News - Y&#039;all Politics"></span><meta itemprop="headline " content="President Biden tapping into Strategic Petroleum Reserve to ease prices, raising ire of Republicans"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://yallpolitics.com/wp-content/uploads/2021/05/Screen-Shot-2021-05-04-at-1.55.14-PM.jpg"><meta itemprop="width" content="788"><meta itemprop="height" content="626"></span> </footer>
<div class="td_block_wrap td_block_related_posts tdi_3_f39 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_3_f39"><script>var block_tdi_3_f39 = new tdBlock();
block_tdi_3_f39.id = "tdi_3_f39";
block_tdi_3_f39.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_3_f39","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":81812,"live_filter_cur_post_author":"30","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_3_f39","tdc_css_class_style":"tdi_3_f39_rand_style"}';
block_tdi_3_f39.td_column_number = "3";
block_tdi_3_f39.block_type = "td_block_related_posts";
block_tdi_3_f39.post_count = "3";
block_tdi_3_f39.found_posts = "38502";
block_tdi_3_f39.header_color = "";
block_tdi_3_f39.ajax_pagination_infinite_stop = "";
block_tdi_3_f39.max_num_pages = "12834";
tdBlocksArray.push(block_tdi_3_f39);
</script><h4 class="td-related-title td-block-title"><a id="tdi_4_316" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_3_f39" href="#">RELATED ARTICLES</a><a id="tdi_5_f99" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_3_f39" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_3_f39 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://yallpolitics.com/2021/11/23/wicker-hyde-smith-announce-261-7-million-army-contract-to-louisville-company/" rel="bookmark" class="td-image-wrap " title="Wicker, Hyde-Smith announce $261.7 million army contract to Louisville company"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Wicker, Hyde-Smith announce $261.7 million army contract to Louisville company" data-type="image_tag" data-img-url="https://yallpolitics.com/wp-content/uploads/2021/08/Wicker-and-Hyde-Smith-218x150.jpg" width="218" height="150" /></a></div> <a href="https://yallpolitics.com/category/2021/" class="td-post-category">2021</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://yallpolitics.com/2021/11/23/wicker-hyde-smith-announce-261-7-million-army-contract-to-louisville-company/" rel="bookmark" title="Wicker, Hyde-Smith announce $261.7 million army contract to Louisville company">Wicker, Hyde-Smith announce $261.7 million army contract to Louisville company</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://yallpolitics.com/2021/11/22/state-senate-district-32-special-election-runoff-is-tuesday/" rel="bookmark" class="td-image-wrap " title="State Senate District 32 special election runoff is Tuesday"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="State Senate District 32 special election runoff is Tuesday" data-type="image_tag" data-img-url="https://yallpolitics.com/wp-content/uploads/2020/06/191010-special-election-button-STK-218x150.jpg" width="218" height="150" /></a></div> <a href="https://yallpolitics.com/category/2021/" class="td-post-category">2021</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://yallpolitics.com/2021/11/22/state-senate-district-32-special-election-runoff-is-tuesday/" rel="bookmark" title="State Senate District 32 special election runoff is Tuesday">State Senate District 32 special election runoff is Tuesday</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://yallpolitics.com/2021/11/22/jones-county-supervisor-arrested-for-embezzlement/" rel="bookmark" class="td-image-wrap " title="Jones County Supervisor arrested for embezzlement"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Jones County Supervisor arrested for embezzlement" data-type="image_tag" data-img-url="https://yallpolitics.com/wp-content/uploads/2021/08/Screen-Shot-2021-08-02-at-10.50.18-AM-218x150.jpg" width="218" height="150" /></a></div> <a href="https://yallpolitics.com/category/2021/" class="td-post-category">2021</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://yallpolitics.com/2021/11/22/jones-county-supervisor-arrested-for-embezzlement/" rel="bookmark" title="Jones County Supervisor arrested for embezzlement">Jones County Supervisor arrested for embezzlement</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_3_f39" data-td_block_id="tdi_3_f39"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_3_f39" data-td_block_id="tdi_3_f39"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
<div id="disqus_thread"></div>
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside id="text-2" class="td_block_template_1 widget text-2 widget_text"> <div class="textwidget"><div class='code-block code-block-2' style='margin: 8px 0; clear: both;'>

<script type="text/javascript" src="https://g.adspeed.net/ad.php?do=js&zid=95027&oid=23225&wd=-1&ht=-1&target=_blank"></script>
</div>
</div>
</aside><div class="td_block_wrap td_block_3 td_block_widget tdi_6_609 td-pb-border-top td_block_template_1 td-column-1 td_block_padding" data-td-block-uid="tdi_6_609">
<style>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</style><script>var block_tdi_6_609 = new tdBlock();
block_tdi_6_609.id = "tdi_6_609";
block_tdi_6_609.atts = '{"custom_title":"Block title","custom_url":"","block_template_id":"","header_color":"#","header_text_color":"#","limit":"1","offset":"1","post_ids":"","category_id":"22","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_6_609","block_type":"td_block_3","separator":"","m1_tl":"","show_modified_date":"","el_class":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m1f_title_font_header":"","m1f_title_font_title":"Article title","m1f_title_font_settings":"","m1f_title_font_family":"","m1f_title_font_size":"","m1f_title_font_line_height":"","m1f_title_font_style":"","m1f_title_font_weight":"","m1f_title_font_transform":"","m1f_title_font_spacing":"","m1f_title_":"","m1f_cat_font_title":"Article category tag","m1f_cat_font_settings":"","m1f_cat_font_family":"","m1f_cat_font_size":"","m1f_cat_font_line_height":"","m1f_cat_font_style":"","m1f_cat_font_weight":"","m1f_cat_font_transform":"","m1f_cat_font_spacing":"","m1f_cat_":"","m1f_meta_font_title":"Article meta info","m1f_meta_font_settings":"","m1f_meta_font_family":"","m1f_meta_font_size":"","m1f_meta_font_line_height":"","m1f_meta_font_style":"","m1f_meta_font_weight":"","m1f_meta_font_transform":"","m1f_meta_font_spacing":"","m1f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"tdi_6_609","tdc_css_class_style":"tdi_6_609_rand_style"}';
block_tdi_6_609.td_column_number = "1";
block_tdi_6_609.block_type = "td_block_3";
block_tdi_6_609.post_count = "1";
block_tdi_6_609.found_posts = "1771";
block_tdi_6_609.header_color = "#";
block_tdi_6_609.ajax_pagination_infinite_stop = "";
block_tdi_6_609.max_num_pages = "1770";
tdBlocksArray.push(block_tdi_6_609);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Block title</span></h4></div><div id=tdi_6_609 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_1 td_module_wrap td-animation-stack">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://yallpolitics.com/2021/11/17/thousands-of-jobs-saved-as-ingalls-shipbuilding-suspends-deadline-for-employees-to-receive-covid-vaccinations/" rel="bookmark" class="td-image-wrap " title="Thousands of jobs saved as Ingalls Shipbuilding suspends deadline for employees to receive COVID vaccinations"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC" alt="" title="Thousands of jobs saved as Ingalls Shipbuilding suspends deadline for employees to receive COVID vaccinations" data-type="image_tag" data-img-url="https://yallpolitics.com/wp-content/uploads/2021/09/Ingalls-324x160.jpg" width="324" height="160" /></a></div> <a href="https://yallpolitics.com/category/business/" class="td-post-category">Business</a> </div>
<h3 class="entry-title td-module-title"><a href="https://yallpolitics.com/2021/11/17/thousands-of-jobs-saved-as-ingalls-shipbuilding-suspends-deadline-for-employees-to-receive-covid-vaccinations/" rel="bookmark" title="Thousands of jobs saved as Ingalls Shipbuilding suspends deadline for employees to receive COVID vaccinations">Thousands of jobs saved as Ingalls Shipbuilding suspends deadline for employees...</a></h3>
<div class="td-module-meta-info">
<span class="td-post-author-name"><a href="https://yallpolitics.com/author/frank/">Frank Corder</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-11-17T07:16:59-06:00">November 17, 2021</time></span> <span class="td-module-comments"><a href="https://yallpolitics.com/2021/11/17/thousands-of-jobs-saved-as-ingalls-shipbuilding-suspends-deadline-for-employees-to-receive-covid-vaccinations/#respond">0</a></span> </div>
</div>
</div> </div></div> <aside id="text-4" class="td_block_template_1 widget text-4 widget_text"> <div class="textwidget"><div class='code-block code-block-8' style='margin: 8px 0; clear: both;'>

<script type="text/javascript" src="https://g.adspeed.net/ad.php?do=js&zid=93489&oid=23225&wd=-1&ht=-1&target=_blank"></script>
</div>
</div>
</aside><aside id="text-5" class="td_block_template_1 widget text-5 widget_text"> <div class="textwidget"><div class='code-block code-block-7' style='margin: 8px 0; clear: both;'>

<script type="text/javascript" src="https://g.adspeed.net/ad.php?do=js&zid=96890&oid=23225&wd=-1&ht=-1&target=_blank"></script>
</div>
</div>
</aside><aside id="custom_html-2" class="widget_text td_block_template_1 widget custom_html-2 widget_custom_html"><div class="textwidget custom-html-widget"><br>
<a class="twitter-timeline" href="https://twitter.com/MSyallpolitics/lists/yallpolitics" data-widget-id="719542708126269440" data-chrome="nofooter noborders">Tweets from https://twitter.com/MSyallpolitics/lists/yallpolitics</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
<script src="https://widgets.twimg.com/j/2/widget.js"></script></div></aside><aside id="text-6" class="td_block_template_1 widget text-6 widget_text"> <div class="textwidget"><div class='code-block code-block-9' style='margin: 8px 0; clear: both;'>

<script type="text/javascript" src="https://g.adspeed.net/ad.php?do=js&zid=96891&oid=23225&wd=-1&ht=-1&target=_blank"></script>
</div>
</div>
</aside><aside id="text-7" class="td_block_template_1 widget text-7 widget_text"> <div class="textwidget"><p><iframe style="border: none; overflow: hidden; width:100%; height: 325px;" src="https://www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2Fpages%2FYallPolitics%2F129921337078906&amp;width=325&amp;colorscheme=light&amp;show_faces=true&amp;border_color&amp;stream=false&amp;header=false&amp;height=400" frameborder="0" scrolling="no"></iframe></p>
</div>
</aside> </div>
</div>
</div> 
</article> 
</div> 
</div> 


<div class="custom_newsletter">
</div>

<div class="td-sub-footer-container td-container-wrap td_stretch_container">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
<div class="menu-td-demo-footer-menu-container"><ul id="menu-td-demo-footer-menu" class="td-subfooter-menu"><li id="menu-item-836" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-836"><a href="https://yallpolitics.com/category/daily-roundup/">Daily Roundup</a></li>
<li id="menu-item-307" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-307"><a href="https://yallpolitics.com/category/ms-legislature/">MS Legislature</a></li>
<li id="menu-item-303" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-303"><a href="https://yallpolitics.com/category/elected-officials/">Elected Officials</a></li>
<li id="menu-item-302" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-302"><a href="https://yallpolitics.com/category/dc/">DC</a></li>
<li id="menu-item-78262" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-78262"><a href="https://yallpolitics.com/category/economicfreedom/">Economic Freedom</a></li>
<li id="menu-item-305" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-305"><a href="https://yallpolitics.com/category/features/">Features</a></li>
<li id="menu-item-301" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-301"><a href="https://yallpolitics.com/about-us/">About Us</a></li>
</ul></div> </div>
<div class="td-pb-span td-sub-footer-copy">
&copy; 2005-2017 Jackson New Media, Inc. All rights reserved. </div>
</div>
</div>
</div>
</div>
<!--googleoff: all--><div id="cookie-law-info-bar" data-nosnippet="true"><span>This website uses cookies to improve your experience. We'll assume you're ok with this, but you can opt-out if you wish. <a role='button' tabindex='0' class="cli_settings_button" style="margin:5px 20px 5px 20px;">Cookie settings</a><a role='button' tabindex='0' data-cli_action="accept" id="cookie_action_close_header" class="medium cli-plugin-button cli-plugin-main-button cookie_action_close_header cli_action_button" style="display:inline-block;  margin:5px; ">ACCEPT</a></span></div><div id="cookie-law-info-again" style="display:none;" data-nosnippet="true"><span id="cookie_hdr_showagain">Privacy & Cookies Policy</span></div><div class="cli-modal" data-nosnippet="true" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true">
<div class="cli-modal-dialog" role="document">
<div class="cli-modal-content cli-bar-popup">
<button type="button" class="cli-modal-close" id="cliModalClose">
<svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg>
<span class="wt-cli-sr-only">Close</span>
</button>
<div class="cli-modal-body">
<div class="cli-container-fluid cli-tab-container">
<div class="cli-row">
<div class="cli-col-12 cli-align-items-stretch cli-px-0">
<div class="cli-privacy-overview">
<h4>Privacy Overview</h4> <div class="cli-privacy-content">
<div class="cli-privacy-content-text">This website uses cookies to improve your experience while you navigate through the website. Out of these cookies, the cookies that are categorized as necessary are stored on your browser as they are essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may have an effect on your browsing experience.</div>
</div>
<a class="cli-privacy-readmore" aria-label="Show more" tabindex="0" role="button" data-readmore-text="Show more" data-readless-text="Show less"></a> </div>
</div>
<div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container">
<div class="cli-tab-section">
<div class="cli-tab-header">
<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab">
Necessary </a>
<div class="wt-cli-necessary-checkbox">
<input type="checkbox" class="cli-user-preference-checkbox" id="wt-cli-checkbox-necessary" data-id="checkbox-necessary" checked="checked" />
<label class="form-check-label" for="wt-cli-checkbox-necessary">Necessary</label>
</div>
<span class="cli-necessary-caption">Always Enabled</span> </div>
<div class="cli-tab-content">
<div class="cli-tab-pane cli-fade" data-id="necessary">
<div class="wt-cli-cookie-description">
Necessary cookies are absolutely essential for the website to function properly. This category only includes cookies that ensures basic functionalities and security features of the website. These cookies do not store any personal information. </div>
</div>
</div>
</div>
<div class="cli-tab-section">
<div class="cli-tab-header">
<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="non-necessary" data-toggle="cli-toggle-tab">
Non-necessary </a>
<div class="cli-switch">
<input type="checkbox" id="wt-cli-checkbox-non-necessary" class="cli-user-preference-checkbox" data-id="checkbox-non-necessary" checked='checked' />
<label for="wt-cli-checkbox-non-necessary" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Non-necessary</span></label>
</div> </div>
<div class="cli-tab-content">
<div class="cli-tab-pane cli-fade" data-id="non-necessary">
<div class="wt-cli-cookie-description">
Any cookies that may not be particularly necessary for the website to function and is used specifically to collect user personal data via analytics, ads, other embedded contents are termed as non-necessary cookies. It is mandatory to procure user consent prior to running these cookies on your website. </div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="cli-modal-footer">
<div class="wt-cli-element cli-container-fluid cli-tab-container">
<div class="cli-row">
<div class="cli-col-12 cli-align-items-stretch cli-px-0">
<div class="cli-tab-footer wt-cli-privacy-overview-actions">
<a id="wt-cli-privacy-save-btn" role="button" tabindex="0" data-cli-action="accept" class="wt-cli-privacy-btn cli_setting_save_button wt-cli-privacy-accept-btn cli-btn">SAVE & ACCEPT</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div>
<div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div>
<!--googleon: all-->
<script type="text/javascript">var cffajaxurl = "https://yallpolitics.com/wp-admin/admin-ajax.php";
var cfflinkhashtags = "true";
</script>
<script>
( function ( body ) {
'use strict';
body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
} )( document.body );
</script>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NBH2ZS3"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>



<style type="text/css" media="screen">
/* custom css theme panel */
#td-top-search {
display: none;
}
</style>
<script type='text/javascript' id='google_cse_v2-js-extra'>
/* <![CDATA[ */
var scriptParams = {"google_search_engine_id":"001198487884543560039:mbuoghkvhf0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/wp-google-search/assets/js/google_cse_v2.js?ver=1' id='google_cse_v2-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"yallpolitics"};
/* ]]> */
</script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"81812 https:\/\/yallpolitics.com\/?p=81812","disqusShortname":"yallpolitics","disqusTitle":"President Biden tapping into Strategic Petroleum Reserve to ease prices, raising ire of Republicans","disqusUrl":"https:\/\/yallpolitics.com\/2021\/11\/23\/president-biden-tapping-into-strategic-petroleum-reserve-to-ease-prices-raising-ire-of-republicans\/","postId":"81812"};
/* ]]> */
</script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-users.js?ver=1.13.1' id='gtm4wp-user-reg-login-script-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/themes/newspaper-child/js/custom.js?ver=1637684899' id='custom_js-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.9.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-includes/js/comment-reply.min.js?ver=5.8.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/custom-facebook-feed/assets/js/cff-scripts.js?ver=4.0.2' id='cffscripts-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://yallpolitics.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>
<script>
jQuery(document).ready(function($){
console.log("Add Code");
$('.td-post-content').after('<a href=https://yallpolitics.com/support-yall-politics/><img class="alignnone size-full wp-image-75871" src=https://yallpolitics.com/wp-content/uploads/2021/04/Donate-Footer.png alt="" width="728" height="90" style="opacity:1" /></a>');
});
</script>

<script>
jQuery().ready(function jQuery_ready() {
tdAjaxCount.tdGetViewsCountsAjax("post","[81812]");
});
</script>

<style>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</style>
<script>
(function($){
$('.td-theme-wrap .td-main-content-wrap.td-main-page-wrap.td-container-wrap .tdc-content-wrap').addClass('content_main');
$('.td-theme-wrap .td-container.td-pb-article-list').addClass('content_main_sidebar');
$('.content_main .vc_column_container.td-pb-span8').addClass('content-main-footer');
})(jQuery);
</script>
<script>
jQuery(document).ready(function(){
setTimeout(function(){
jQuery('.custom_search').append(jQuery('#custom_search'));
},500)
})
</script>
</body>
</html>